APS Excellence in Physics Education Award
November 2019

Education Prize Logo
Science SPORE Prize
November 2011

NSF Logo
The Open Source Physics Project is supported by NSF DUE-0442581.

Xuggle video engine doesn't work post and replies

Return to the Xuggle video engine doesn't work thread
Login to post to this thread

Xuggle video engine doesn't work in new update (6.0.2), can not upload videos
Isuru Bhathiya
4 Posts

After installing the new update(6.0.2) it shows the message "The Xuggle video engine is not working or not installed". According to its instructions, I checked the information (a screenshot was attached below.) in the help/Diagnostic/About Xuggle. Then according to its instructions, I copied the jars from the source directory to the code base directory. But still have the issue. Because of this issue, I cannot upload any video to the tracker.

Attached File: 2198_Screenshot2.png


Replies to Xuggle video engine doesn't work in new update (6.0.2), can not upload videos

Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Douglas Brown Avatar
Douglas Brown
339 Posts

Can you tell us what OS you are using? Also, what is the JRE path shown when you choose Help|Diagnostics|About Java? Doug


> After installing the new update(6.0.2) it shows the
> message "The Xuggle video engine is not working or
> not installed". According to its instructions, I checked
> the information (a screenshot was attached below.)
> in the help/Diagnostic/About Xuggle. Then according
> to its instructions, I copied the jars from the source
> directory to the code base directory. But still have
> the issue. Because of this issue, I cannot upload
> any video to the tracker.



Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Isuru Bhathiya
4 Posts

I am currently using Windows 10. But Windows 11 OS is currently available for my PC. therefore I hope to upgrade to it soon. (Should I wait until  u fix this issue?)

The path was

from
C:\Program Files\Tracker\Xuggle

to
C:\Program Files\Tracker



Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Douglas Brown Avatar
Douglas Brown
339 Posts

Isuru, Can you take and attach a screenshot of the contents of C:\Program Files\Tracker? What does Help|About Java show for the jre path?



Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Isuru Bhathiya
4 Posts

A screenshot of the message box that shows in the "Help | About Java" was attached with my very first post. That is the only message I  am getting from the "Help | About Java".

Attached File: Screenshot163.png



Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Douglas Brown Avatar
Douglas Brown
339 Posts

The screenshot in your first post was Help|About Xuggle. I am asking about Help|About Java.



Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Isuru Bhathiya
4 Posts

Here it is

Attached File: Screenshot166.png



Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Douglas Brown Avatar
Douglas Brown
339 Posts

I'm sorry, Isuru, but I don't know why Xuggle doesn't work on your machine. All of your info and screenshots look totally normal and correct. Has anyone else experienced or heard of this issue?

There is something you can do to use Tracker without Xuggle: convert your video clip into an image stack using online video converters such as Online Converter (https://www.onlineconverter.com/video-to-jpg).

I hope this helps!  Doug

> After installing the new update(6.0.2) it shows the
> message "The Xuggle video engine is not working or
> not installed".
> Because of this issue, I cannot upload
> any video to Tracker.



Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Christoph Wissing
2 Posts

Dear Doug,

I have the same issue on Linux and investigated the issue a little bit. I start with a fresh installation of 6.0.3 with my personal local account. Everything works. However when I login with a different (guest) account on the same machine I see the described Xuggle issue. I get it to run, when calling tracker with sudo rights though.

When I reboot the computer and login with the guest account that was problematic before, I can use tracker normally, but now my personal account fails. Running with sudo forces it to run on any account. I reproduced this issue on my desktop running Fedora 34 and two laptops, one with CentOS 8 and one with Ubuntu 21.04.

Most likely the issue is internal to Xuggle and not really something on the Tracker end, but I am lacking competences to further debug this. Did you update Xuggle with one of the recent Tracker releases? Perhaps something bad sneaked in.

Thanks for all that good stuff!

Regards, Christoph



Re: Xuggle video engine doesn't work in new update (6.0.2), can not upload videos -
Christoph Wissing
2 Posts

Hello,

let me answer myself. By chance I found out, what is causing the problem with the video engine, when I switch the accounts as described.

When Tracker is started (on Linux) it creates a directory /tmp/xuggle. Perhaps it is Xuggle creating it and not Tracker  itself. In any case, the directory remains and another user cannot use it due to permission issues. When I make sure, that the /tmp/xuggle directory is not there, I can start Tracker with any account.

If Tracker is control of the directory it can be easily fixed, e.g. by extending the username or a hash. If Xuggle is in charge, relevant developers can certainly do something about.

Perhaps this causes similar effects also on other platforms. Recently there have been a few more reports about problems with the Video engine. From the provided details I would guess it is Windows.

Hope that helps!

Regards, Christoph



OSP Projects:
Open Source Physics - EJS Modeling
Tracker
Physlet Physics
Physlet Quantum Physics
STP Book