APS Excellence in Physics Education Award
November 2019

Education Prize Logo
Science SPORE Prize
November 2011

NSF Logo
The Open Source Physics Project is supported by NSF DUE-0442581.

Tracker 4.87 beta post and replies

Return to the Tracker 4.87 beta thread
Login to post to this thread

new Tracker fixes Yosemite
Douglas Brown Avatar
Douglas Brown
339 Posts

Hi all,

I've got a new beta Tracker installer that should fix the Yosemite issue :-) 

It always does a "full" install--there's no "upgrade" option even when Tracker is already installed. And you will see there is no "Xuggle" option either. This is because Tracker now includes its own "private" Xuggle automatically. On OSX, Xuggle runs in both the Oracle Java 7/8 JREs and Mac's own Java 6 JRE running in 64-bit mode (the default).

If you have Mac's own Java 6 JRE installed, then this new version should also restore the use of QuickTime even on Yosemite (but still only in 32-bit VM, available only with Java 6).

I have tested on my own Yosemite machine but I still need more testing. Could I ask the OSX users among you to download and run the installer from www.cabrillo.edu/~dbrown/tracker/installers/Tracker-4.87-osx-installer.zip and let me or the whole group know how the new version works for you?


I'd also like feedback from Windows and Linux users, of course! Here are the links for your beta installers:

www.cabrillo.edu/~dbrown/tracker/installers/Tracker-4.87-windows-installer.exe

www.cabrillo.edu/~dbrown/tracker/installers/Tracker-4.87-linux-32bit-installer.run

www.cabrillo.edu/~dbrown/tracker/installers/Tracker-4.87-linux-64bit-installer.run

A major change in this new version is that the installer no longer sets any global environment variables like TRACKER_HOME, etc. Instead, TrackerStarter defines the environment. This, along with the private Xuggle engine, should make Tracker much less susceptible to failure caused by security restrictions imposed by the OS or Java VM. (This is what broke it in Yosemite.) I have high hopes for this new version but it does need testing--thank you in advance to all of you!

best regards,

Doug


Replies to new Tracker fixes Yosemite

Re: new Tracker fixes Yosemite -
Mauricio Mendivelso-Villaquiran
2 Posts

Testing new Tracker on mac

Computer: Apple MacBook Pro with clear Yosemite installation. No other non-Yosemite Tracker files at all.

Begin installation: download the program, uncompress and double-click on the installer

Output: "There has been an error. Java 1.6 or greater is required to install and run Tracker. The installer will now close."

Download Java at www.java.com and download Java version 8 update 25 and install (and verify as is suggested in the installation proccess)

Trying installation again: cliking... initial screen... accepting incoming network connections... accepting default options... done.

Double cliking on the Tracker App... Output: "To open "Tracker" you need to install the legacy Java SE 6 runtime." (Press "More info..." button redirect browser to http://support.apple.com/kb/DL1572)

Downloading and installing Java for OS X 2014-001... done

New try: Double cliking on the Tracker App... Output: "The Java VM was started in 64-bit mode (32-bit not support)." In Preferences..Video... no video engine is selected. Xuggle must be selected and Tracker relaunched.

New try: Double cliking on the Tracker App... Output:none. I tried to load a .mov video and... all is ok! I tried to load a .mp4 and all goes well.

Test passed.



Re: new Tracker fixes Yosemite -
Fabián Martínez Velandia
3 Posts

Doug, this version works with 32-bit and 64-bit. Thanks a lot.



Re: new Tracker fixes Yosemite -
paul macdermid
2 Posts

Seems to have downloaded ok but when trying to import video it stalls out at 20%. Any fixes for this?



Re: Re: new Tracker fixes Yosemite -
Douglas Brown Avatar
Douglas Brown
339 Posts

Did you install the release version (dated 11/9/14 in the About Tracker dialog)? If not, please do.

If the probem persists, try this: open the message log (Help|Diagnostics|Message Log), set the level to ALL, and try to import your video. Do the logged messages help identify the problem?

If the video is not too long, you could send it to me (email on the Tracker web site) and I can take a look. If the problem is on OSX (as I assume it is) then you need to get the video to me by the end of this week as I won't have access to my Mac for some time after that.

Doug

You said:

Seems to have downloaded ok but when trying to import video it stalls out at 20%. Any fixes for this?



Re: Re: Re: new Tracker fixes Yosemite -
paul macdermid
2 Posts

Hi, I have 4.87 Nov 9 installed but am running yosemite on a macbook pro. I have previously been able to install video up until the upgrade to yosemite. the forum site won't allow the video to be attached.



Re: new Tracker fixes Yosemite -
Ole Bjørn Kristensen
2 Posts

I have previously posted the following "I downloaded and used Tracker a few months ago. BUT, now I just get an error message:

"The registry refers to a nonexistent JRE installation or the runtime is corrupted.."

I use other java programs that are running perfectly well. Do you have any sugestions as to what I might do to get Tracker running?
I already uninstalled the version of the program I had at the time and installed the most recent one, but the error message remained.
"

The computer department at my school now reports the following:
"To install Tracker I had to configure Java to get it's runtime environment setting from C:\Program Files (x86)\Java because Tracker is installed here. If I had only installed Java 32-bit this probably would not have been an issue, but since I have installed both 32-bit and 64-bit, I had to do it this way. This could be useful information for users. "

Tracker is now running fine!
:)



Re: new Tracker fixes Yosemite -
Germain Goh
1 Posts

Hey Doug,

so after updating to yosemite, everytime i try to open tracker, it gives me this message "to open tracker you need to install the legacy Java SW 6 runtime." I've tried downloading the latest update of java multiple times but to no avail. Can you please help me on this matter? I've got a school project which requires the use of tracker and its not working!! Thank you so much



Re: Re: new Tracker fixes Yosemite -
Douglas Brown Avatar
Douglas Brown
339 Posts

Germain--You may have to install the Java supplied by Apple. You can get it here:  http://support.apple.com/kb/DL1572

If that doesn't work, try uninstalling/reinstalling Tracker.

Hope this helps. Doug

 

> Re: Re: new Tracker fixes Yosemite > > Hey Doug, > > so after updating to yosemite, everytime > i try to open tracker, it gives me this message "to > open tracker you need to install the legacy Java SW > 6 runtime." I've tried downloading the latest update > of java multiple times but to no avail. Can you please > help me on this matter? I've got a school project > which requires the use of tracker and its not working!! > Thank you so much



OSP Projects:
Open Source Physics - EJS Modeling
Tracker
Physlet Physics
Physlet Quantum Physics
STP Book