APS Excellence in Physics Education Award
November 2019

Education Prize Logo
Science SPORE Prize
November 2011

NSF Logo
The Open Source Physics Project is supported by NSF DUE-0442581.

profile not calibrating post and replies

Return to the profile not calibrating thread
Login to post to this thread

profile not calibrating
Kaisa Young
3 Posts

Been using Tracker in our physics labs for years to analyze spectra. But this year got the new version and the profile x-axis doesn't calibrate automatically after using Calibration Points (x-only). Is there an additional step now? How can we get the profile and columns to update with the calibration? Photo attached showing profile with non-calibrated x-axis.
Thanks!

Attached File: trackerscreen.png


Replies to profile not calibrating

Re: profile not calibrating -
Douglas Brown Avatar
Douglas Brown
370 Posts

Kalsa, I just tried this and calibrating a line profile with calibration points works fine on my Windows 11.  Can you tell us more? Is it reproducible, and if so, how?  Use these guidelines:  https://www.compadre.org/osp/items/detail.cfm?ID=16061  Thanks!


> Been using Tracker in our physics labs for years to
> analyze spectra. But this year got the new version
> and the profile x-axis doesn't calibrate automatically
> after using Calibration Points (x-only). Is there
> an additional step now? How can we get the profile
> and columns to update with the calibration? Photo
> attached showing profile with non-calibrated x-axis



Re: profile not calibrating -
Kaisa Young
3 Posts

Hi Douglas,
I tried it again with the library browser gas_H.mp4 and still have the same issue. Attached screenshot. Yesterday, I had an .mov file.
I'm using a Dell laptop with Win 11 Pro 21H2. Tracker version 6.0.8 and Java is from the Tracker folder v9.0.4.
I have the same issue on a Dell desktop running Win10 Pro 1909 with same version of Tracker and Java and the same .mp4 file.
Here are the steps I used: import video, new line profile, change spread to 20, new calibration points, x-only, click on green & red laser, enter wavelengths (543, 633), right click on number box to change units nm.
Appreciate your help!
Kaisa

Attached File: image3.png



Re: profile not calibrating -
Douglas Brown Avatar
Douglas Brown
370 Posts

Thanks Kalsa. Yes, I can now reproduce it and it is indeed a bug that needs fixing. But it's just a data refresh bug--here are 2 easy work-arounds for now :-)

1. You won't see the bug at all if you calibrate first, then create the line profile.
2. If you calibrate after creating the line profile, then just select the center (cross) of the line profile, nudge it one pixel to the right (right arrow key), then one pixel back. The data will refresh to the correctly scaled values.

Doug

> Here are the steps I used: import
> video, new line profile, change spread to 20, new
> calibration points, x-only, click on green & red laser,
> enter wavelengths (543, 633), right click on number
> box to change units nm.



Re: profile not calibrating -
Kaisa Young
3 Posts

Thanks so much! Those suggestions worked. I appreciate your help!



OSP Projects:
Open Source Physics - EJS Modeling
Tracker
Physlet Physics
Physlet Quantum Physics
STP Book