Education Prize Logo
Science SPORE Prize
November 2011

NSF Logo
The Open Source Physics Project is supported by NSF DUE-0442581.

issue with _view.addPoint() function post and replies

Return to the issue with _view.addPoint() function thread
Login to post to this thread

issue with calling _view.addPoint - Jul 19, 2012 at 2:09PM
Nick Gross
13 Posts

During my initialization, I would like to draw several curves in 3D that will be static during the evolution.  The curves do not have a functional form and I am drawing them using and update scheme. I set up a Trail3D object for each curve and explicitly calling _view.addPoint from a loop in my initialization. This worked fine in a previous release of EJS, but with the most recent update it fails.

With the current update, no error is generated and the code seems to run and the display window opens but it is all grey and nothing, not even the other objects, seem to be displayed.  Worse yet, it does not look like I can recreate this issue routinely.

Has anyone else seen this error?
Is there a better way to do what I want to do?

Thanks for the help


Replies to issue with calling _view.addPoint

Re: issue with calling _view.addPoint - Jul 19 2012 3:55PM
Francisco Esquembre
130 Posts

Nick,

I don't think I have introduced any change that may justify the difference with previous EJS releases.

Could you please email me the example that causes this problem? I'd like to have a close look at it.

Paco
email: fem@um.es



Re: issue with calling _view.addPoint - Jul 19 2012 10:24PM
Wolfgang
70 Posts

The Lorenz Attractor model draws a 3D trail with 10,000 points in the initialization section of the model.  I have just tested it with the latest version of EJS 4.3.7.

http://www.compadre.org/osp/items/detail.cfm?ID=8986



The OSP Network:
Open Source Physics - Tracker - EJS Modeling
Physlet Physics
Physlet Quantum Physics