Education Prize Logo
Science SPORE Prize
November 2011

NSF Logo
The Open Source Physics Project is supported by NSF DUE-0442581.

Is the minimum version of Java required for EJS 5.2 Java 8?

Return to the EJS Modeling forum
Login to post to this thread

Is the minimum version of Java required for EJS 5.2 Java 8? - Mar 7 at 4:33PM
Cleon Teunissen
11 Posts

As mentioned in an earlier message I recently returned to EJS editing after a long hiatus. At first I used the Java and EJS versions I had still sitting around: JRE 7u41 and EJS 5.0_140730
(On my system Java is used for EJS only, and very early on I had kicked Java out of my browsers; my copy of JRE 7 was not in any way internet-facing, so I didn't bother with updates.)

When I had downloaded EJS 5.2_161123 it did not start at all. Nothing at all happened.

To check whether it was a Java version issue I downloaded the latest JRE: JRE 8u121. I uninstalled the existing Java installation, installed the latest, and this time EJS 5.2_161123 started normally.

Hence my question, does EJS 5.2 require at least Java 8?


(What I forgot to do is to look for some Java log that might have an entry at the point where I tried to start EJS 5.2 with JRE 7. Paco, if you want I can re-install JRE 7, and then try to see if any log entry is made.)


Cleon


The OSP Network:
Open Source Physics - Tracker - EJS Modeling
Physlet Physics
Physlet Quantum Physics